ACM:LCM Walk

A frog has just learned some number theory, and can't wait to show his ability to his girlfriend.

Now the frog is sitting on a grid map of infinite rows and columns. Rows are numbered 1,2,⋯ from the bottom, so are the columns. At first the frog is sitting at grid (sx,sy), and begins his journey.

To show his girlfriend his talents in math, he uses a special way of jump. If currently the frog is at the grid (x,y), first of all, he will find the minimum z that can be divided by both x and y, and jump exactly z steps to the up, or to the right. So the next possible grid will be (x+z,y), or (x,y+z).

After a finite number of steps (perhaps zero), he finally finishes at grid (ex,ey). However, he is too tired and he forgets the position of his starting grid!

It will be too stupid to check each grid one by one, so please tell the frog the number of possible starting grids that can reach (ex,ey)!

Input
First line contains an integer T, which indicates the number of test cases.

Every test case contains two integers ex and ey, which is the destination grid.
⋅ 1≤T≤1000
⋅ 1≤ex,ey≤109

Output
For every test case, you should output " Case #x: y", where x indicates the case number and counts from 1 and y is the number of possible starting grids.

Sample Input
3
6 10
6 8
2 8

Sample Output
Case #1: 1
Case #2: 2
Case #3: 3

一开始没有用根据一对数直接算原来的数的方法,而是一个数一个数去试就超时了,后来计算了下直接的算法、

  • 打字有点麻烦,下面是手写的过程.......
这里写图片描述
  • 代码
#include <stdio.h>

int gcd(int x1, int y1)
{
    int x = (x1 < y1) ? x1 : y1; // 较小数
    int y = (x1 < y1) ? y1 : x1; // 较大数
    while ( x != 0) {
        int a = y%x;
        y = x;
        x = a;
    }
    
    return y;
}

int main()
{
    int T;
    scanf("%d",&T);
    int a = 1;
    for ( ; a <= T; a++) {
        int num = 0;
        int x1,y1;
        scanf("%d %d", &x1, &y1);
        int max_gcd = gcd(x1,y1);
        while ( max_gcd == gcd(x1,y1)) {
            num++;
            int x = (x1 < y1) ? x1 : y1; // 较小数
            int y = (x1 < y1) ? y1 : x1; // 较大数
            if (y%(1+x/max_gcd) != 0) {
                break;
            }
            y1 = y/(1+x/max_gcd);
            x1 = x;
            printf("%d %d\n", x1, y1);
        }
        
        printf("Case #%d: %d\n", a, num);
    }
    return 0;
}

哈哈哈哈哈哈